Sintoma:
Desde una computadora con Windows Vista Business se presenta un error de usuario o password incorrecto en los siguientes escenarios:
- Intentar accesar un recurso compartido en una PC con Windows XP Profesional.
- Intentar accesar un recurso compartido en un servidor con Samba.
- Intentar unirse a un dominio de Samba.
Causa:
Windows Vista usa por default autenticación NTLMv2, que no es compatible con Windows XP Profesional o con la versión de Samba probada (ver sección Probado con).
Solución:
- En la PC con Windows Vista ingrese con una cuenta de administrador, haga clic en el botón Inicio, luego en el campo de busqueda (Iniciar busqueda) escriba: secpol.msc
- En el arbol de opciones de la izquierda de la ventana "Directivas de seguridad local", haga doble clic en "Directivas locales", luego clic en "Opciones de seguridad".
- En la lista que aparece a la derecha ubique la directiva "Seguridad de red: Nivel de autenticación de LAN Manager" y haga doble clic.
- Haga un clic en la lista de selección y luego haga clic en la opción "Enviar LM y NTLM: usar la seguridad de sesión NTLMv2 si se negocia".
- Haga clic en Aceptar. Cierre la ventana "Directivas de seguridad local" e intente nuevamente.
Probado con:
- Windows Vista Business
- Windows XP Profesional SP2
- Samba 3.0.2a-51